How to participate in XCITE 5000 block test

Discussion in 'Testnet / Development' started by XTRABYTES, Nov 21, 2017.

Thread Status:
Not open for further replies.
  1. XTRABYTES

    XTRABYTES Well-Known Member

    Messages:
    244
    Likes Received:
    259
    Trophy Points:
    63
    Step 1: Download XCITE wallet
    https://drive.google.com/open?id=1ti1EU-vH-YSPhZHO_y0q26RUkIwVvg88

    Step 2: Create config file

    You can only participate if you're public key has been compiled into the wallet, please check you're public key on the following list before proceeding:
    https://drive.google.com/file/d/124JhZn_gewGKdK_KQT1vdaZKE0uWFTje/view?usp=sharing

    If it is not on the list then please DM Danny1987 or Yankeeruinx for a new set of keys.

    Within appdata/roaming/xcite (if you do not have an xcite folder yet, run the wallet once and close it)
    Create a new xcite.conf file with the following contents:

    posignkey=your_posign_private_key

    screen1.jpg
    Save config and exit.

    Step 3:Check Debug.log
    Now you can start the wallet and in you're roaming folder there will be a file called debug.log, please open this file and search for "importable". Then copy the code.
    PLEASE NOTICE NOT TO COPY THE "init", "added" or "upnp" AT THE END.

    screen2.jpg

    Now you can open the wallet debug console by opening the wallet -> help -> debug windows -> console.

    Now type "importprivkey <copied code>" and press return / enter.

    screen3.jpg

    Step 4: Check if everything works
    Now you're client is setup to mine to can check you're miner ID by searching you're public in the following list:
    https://drive.google.com/file/d/124JhZn_gewGKdK_KQT1vdaZKE0uWFTje/view?usp=sharing

    Once you have found you're ID you can look at the block explorer if you're clients has found any blocks:
    http://xcite.xtrabytes.services/index.php

    Step 5: Adding address
    As a final step we would like everybody to leave his XCITE address on this sheet so we can test even more with transactions:

    https://docs.google.com/spreadsheets/d/1XlIELiZ2C7YV40SOHLBNHtNg9b59s9MI5J00tL2bzvg/edit#gid=0
     
    Last edited by a moderator: Nov 21, 2017
    Shixy, Yankee Ruin X and fish313 like this.
  2. enervey

    enervey Member

    Messages:
    29
    Likes Received:
    8
    Trophy Points:
    8
    Thanks for these great instructions! I received the test XBY after completing the steps and look forward to being part of the testing.
     
  3. Shixy

    Shixy Member

    Messages:
    69
    Likes Received:
    34
    Trophy Points:
    18
    These would be great instructions for all. Thanks for beefing the instructions clearer for the rest!
     
  4. fish313

    fish313 Well-Known Member Staff Member

    Messages:
    106
    Likes Received:
    84
    Trophy Points:
    28
    Followed directions up to finding the "importable" key. It doesn't show in the debug log. Maybe because I'm not synced to the network? Having a hard time connecting. Was showing 3 active connections, now back to 0 and still 18 weeks behind.
     
  5. ByteMe

    ByteMe Member

    Messages:
    34
    Likes Received:
    12
    Trophy Points:
    8
    Just want to add "Pre" to that list, as my debug.log had the word "Pre-allocating" after my key. I think it would be a good idea to update the log generation so that a space follows the key.
     
    SuperAdmin likes this.
  6. Carlos

    Carlos New Member

    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    Same here. Wallet seems to be up to date and connected as as far as I can tell...hmm
     
  7. Yankee Ruin X

    Yankee Ruin X Well-Known Member

    Messages:
    179
    Likes Received:
    96
    Trophy Points:
    28
    Hi, double check your xcite.conf file is correct.

    Have you used your Public Key and not your Private Key?

    Is the file actually a .conf file? To make a .conf file I just used Notepad++ and saved the file exactly as "xcite.conf" including the quotation marks to force it to save as a .conf.

    If that doesn't work then let us know.
     
    Carlos likes this.
  8. niels12

    niels12 Member

    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
    My XCite client is up and running now for 14 hours. No problems, processing lots of transactions.
     
  9. Muhammad Haris

    Muhammad Haris Member

    Messages:
    58
    Likes Received:
    7
    Trophy Points:
    8
    No importable in debug.log and also the public key is not in the compiled public keys list.
     
  10. niels12

    niels12 Member

    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
  11. Carlos

    Carlos New Member

    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
     
    Yankee Ruin X likes this.
  12. Yankee Ruin X

    Yankee Ruin X Well-Known Member

    Messages:
    179
    Likes Received:
    96
    Trophy Points:
    28
    Not sure but mine is 124 so I have been raking it in :tearsofjoy: It does switch between others at certain time periods, not sure why it is doing what it is doing though. Might be down to the rewards setup is not in place yet where things will be distributed more evenly with other variables in place.
     
  13. niels12

    niels12 Member

    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
    Ok, I haven't mined a block yet, but I'm receiving lots of transactions, so I guess it's running fine.
     
    Yankee Ruin X likes this.
  14. fish313

    fish313 Well-Known Member Staff Member

    Messages:
    106
    Likes Received:
    84
    Trophy Points:
    28
    Still cannot connect. Is there a list of nodes I can add to the xcite.conf file to help with connecting?

    I keep getting "connection timeout" in the debug.log
     
Thread Status:
Not open for further replies.

Share This Page